Créer un rapport d'incident

SommaireRocview

  • Incident


Emplacement dans le menu Rocview → Aide → Incident
Icône de la barre d'outils ou


Démarrage rapide

Si vous reportez un problème dans le Forum Rocrail vous devez fournir certains fichiers essentiels que vous pouvez facilement collecter avec cette fonction en quelques étapes:

  1. Mettre à jour l'installation Rocrail. C'est essentiel!
  2. Ouvrir le menu Aide dans Rocview.
  3. Sélectionner Incident.
  4. Écrire un texte dans le champs Sujet (ne pas utiliser des caractères spéciaux); Par exemple : “Un aiguillage ne marche pas”.
  5. Éventuellement écrire des informations détaillées au sujet de votre question dans la zone texte Description.
  6. Cliquer sur OK.
  7. La fenêtre de l'explorateur de fichiers s'ouvrira avec un fichier nommé issue.zip qui pourra être attaché dans le Forum.
    En bas de l'entrée sur le Forum il y a la fonction “Transférer une pièce jointe”, sélectionnez le fichier issue.zip venant juste d'être créé.


Réseaux modulaires

La création d'un rapport d'incident en cas de réseau modulaire va l'aplatir en un seul fichier de plan.
Compresser le répertoire complet sera le meilleur moyen pour ce type de réseau.


Niveaux de suivi

Activer seulement Les niveaux de suivi du serveur si ils sont réellement nécessaires.

  • Le niveau de suivi “Byte” a uniquement du sens pour les incidents de communication.
  • Le niveau de suivi “Automatic mode” a uniquement du sens pour les incidents lié au mode de fonctionnement automatique.
  • Etc…


Préparation

  1. Désactivez tous les niveaux de trace inutiles.
  2. Préparez l'environnement tel que nécessaire à la reproduction de l'incident
  3. Redémarrez si nécessaire.
  4. Rendez la reproduction de l'incident aussi court que possible.
  5. Écrivez dans la fenêtre de dialogue “Incident” une liste pas-à-pas permettant la reproduction de l'incident.


Localisation de l'incident

Le répertoire d'incidents est définit par défaut dans l'environnement mais peut-être modifié dans l'onglet Généralités.
Dans la fenêtre de suivi du serveur le chemin pleinement qualifié sera affiché.
Si le serveur fonctionne sur le même ordinateur une fenêtre de l'explorateur de fichiers sera ouverte contenant tous les fichiers qui peuvent être compressés dans un seul fichier pour le téléchargement sur le forum. Avec les versions récentes un fichier issue.zip est créé automatiquement.
Un autre chemin facultatif peut être sélectionné si le serveur fonctionne sur le même ordinateur.


Envoyer l'incident

Compressez le répertoire Incident dans un fichier 'issue'.ZIP sur Mac/Windows ou dans un fichier 'issue'.tar.gz sur Linux.
Attachez cette archive 'issue' à votre post sur le Forum.


Menu d'Aide


Exemple

Fenêtre de Dialogue

Sujet

Le sujet de l'incident. (obligatoire)
Ne pas utiliser des caractères spéciaux dans le sujet parce que ils sont utilisés pour construire un nom de fichier, qui peut être dépendant de la plateforme.

Répertoire

Répertoire optionnel pour stocker les fichiers incident au cas ou le serveur fonctionne sur le même ordinateur que Rocview.

Description

Courte description du problème. C'est optionnel mais fortement recommandé.


Contenu du répertoire

issues/le train ne démarre pas./
issue.txt contenu de la fenêtre de dialogue incident et statistiques du serveur
plan.xml Vidage de la mémoire du modèle ce qui inclus tous les fichiers XML séparés des modules et locos. (Le nom du fichier ressemblera au fichier rocrail.ini et pourra être différent, et le chemin précédent sera retiré.)
occ.xml Dump mémoire de l'occupation et du placement
rocrail.ini Vidage mémoire des réglages du serveur. (Le chemin du plan précédent sera retiré.)
rocrail.trc copie du fichier trace actuel

Ces fichiers sont contenus dans un sous-répertoire “issues”.


Rapport

issue.txt:

Date: 20120930.112140.715
Rocrail 2.0.999-4021 Sunrise (linux)

started at Sun Sep 30 11:20:31 2012

process id         = 81373
working directory = /Users/rob/lp/Rocrail/unxbin/virt
allocation count  = 17555
allocated memory  = 3 MB
clients           = 1
connections       = 1
locos             = 2


De trein vertrekt niet.:
----------------------------------------
Ik heb al van alles geprobeerd maar zelfs met een zetje wilt de trein niet gaan rijden.


BackTrace: (last 10 exceptions and warnings)
----------------------------------------
 unable to open file: netroutes.xml
 Error open file [netroutes.xml] [rb]
 Error open file [netroutes.xml] [rb]
 block [03] not found
 block [02] not found
 block [01] not found
 createMap: locationlist NOT found.
 createMap: operatorlist NOT found.
 createMap: waybilllist NOT found.
 createMap: linklist NOT found.

13 threads:
----------------------------------------
timedoff "timedoff"
clockticker "clockticker"
r2rreader "r2rreader"
V200 "Elektrolokomotive E 41 der DB"
infw035C98E0 "127.0.0.1"
broadcast "ClientCon Broadcaster"
tick06F00E00 "tick06F00E00"
checker "checker"
cconmngr "ClientCon Manager"
r2rwriter "r2rwriter"
vcs-1 "vcs-1"
E03 "Elektrolokomotive BR 103 der DB"
cmdr035C98E0 "127.0.0.1"

Définir une entrée dans le Forum comme résolu

Seulement la personne (outre les administrateurs) qui a créé une entrée sur le forum peut le clore.
1. Sélectionner la première entrée de votre message sur le forum.
2. Sélectionner “Edit”
3. Préfixer le titre avec (solved) ou (fixed) ou une description appropriée.
4. Soumettre

Exemple:
Entrée sur le forum:

 The names in the View tab are inconsistent.

Entrée sur le forum après que les changements aient été fait:

 (fixed) The names in the View tab are inconsistent.

Personal Tools