Table of Contents

Rocview: Menü

InhaltRocview Allgemeine Funktionen

  • Suchbegriffe: Lokbedienfeld filtern, sortieren


Siehe auch Rocview-Werkzeugleiste.

Menü-Leiste in Rocview: 1)

Datei - Bearbeiten - Automatik - Gleisplan - Tabellen - Steuerung - Programmieren - Lesezeichen - Ansicht - Hilfe


Menü Datei


Verbinden mit...

Falls Rocview nicht mit einem Server verbunden ist, oder mit einem anderen, als dem aktuellen Server verbunden werden soll, so kann dies mit diesem Dialog eingestellt werden.

Serververbindung trennen

Beendet die Verbindung zum Server, um offline lokal editieren zu können.

Rocview Eigenschaften...

Zum Modifizieren der Eigenschaften von Rocview wie unter Rocview-Eigenschaften einstellen beschrieben.
Dieser Menü-Punkt ist im Rocview-Menü unter Mac OS X.

Rocrail Eigenschaften...

Die meisten Einstellungen sind im Kapitel Konfiguration von Rocrail beschrieben.

Hinweis: Diese Option ist nur verfügbar, wenn Rocview mit einem Rocrail-Server verbunden ist.

Gleisplan-Name...

Zum Ändern des Namens des aktuellen Gleisplanes.

Neu, Öffnen...

Zum Erstellen eines neuen bzw. öffnen eines vorhandenen Gleisplanes.
Siehe auch unter Erstellen / Bearbeiten eines Gleisplanes.

Hinweis: Diese Optionen sind nur verfügbar, wenn Rocview offline ist, d. h. augenblicklich nicht mit einem Rocrail-Server verbunden ist!

Arbeitsbereich öffnen

Zum Öffnen eines Arbeitsbereiches.

Letzte Arbeitsbereiche...

Aus den zuletzt geöffneten Arbeitsbereichen kann ausgewählt werden.

Speichern

Speichert den aktuellen Gleisplan unter seinem augenblicklichen Namen.

Tipp: Der Gleisplan wird beim Beenden von Rocview und Rocrail automatisch gespeichert.

Speichern unter...

Speichert den aktuellen Gleisplan in eine andere Datei.

Hinweis: Wird die Plan-Datei unter einem anderem als dem aktuellen Namen gespeichert, so müssen die Pfadangaben in der rocrail.ini bzw. über das Menü Rocrail Eigenschaften... entsprechend angepasst werden, damit der Server Zugriff auf die so gespeicherte Datei hat!

Ebene speichern als...

Die im Gleisplan aktive / sichtbare Ebene kann als XML-Datei (Ebenenname.xml) gespeichert werden.
Es öffnet sich ein Datei-Dialog, in dem der vorgeschlagene Name und der Speicherort geändert werden kann.

Ebene importieren...

Es öffnet sich ein Datei-Dialog zur Auswahl einer XML-Plandatei zum Import einer Ebene.

Hinweis:
Um im Ziel-Plan das Vermischen mehrerer Ebenen zu verhindern, dürfen Import-Dateien keinen kompletten Gleisplan, sondern nur eine Ebene enthalten.
Für den Import mehrerer Ebenen müssen diese jeweils einzeln in separaten Dateien gespeichert werden.
Schritte:
1. Den Gleisplan, der die gewünschte(n) Ebene(n) enthält, in Rocrail öffnen.
2. Die gewünschte Ebene durch Klick auf die entsprechende Registerkarte auswählen.
3. Mit Ebene speichern als... als XML speichern. (z.B. Ebenenname.xml)

Drucken...

Vor dem Drucken bitte die Umgebung berücksichtigen.

Druckt die ausgewählte Gleisplan-Ebene oder den Modul-Plan.

Analysieren

Analysiert den geladenen Gleisplan.

Hochladen...

:!: Der aktuelle Plan auf dem Sever wird nach einem Hochladen nicht gespeichert, damit ein Aktualisieren moglich ist.

Der Rocrail-Server speichert eine erhaltene Datei unter dem in der Gleisplandatei angegebenen Namen in seinem lokalen Arbeitsverzeichnis.
Der neue Plan kann verwendet werden, nachdem der Name in Eigenschaften von Rocrail geändert und der Server neu gestartet wurde.

Hinweis: Diese Option sollte nur von fortgeschrittenen Benutzern verwendet werden!
Hinweis: Diese Option ist nur verfügbar, wenn Rocview mit einem Rocrail-Server verbunden ist.

Rocrail und Rocview beenden

Beendet Rocview und anschließend den Rocrail-Server.

Hinweis: Diese Option ist nur verfügbar, wenn Rocview momentan mit einem Rocrail-Server verbunden ist und der Server nicht im Konsolen-Modus oder einem zuvor geöffneten Arbeitsbereich läuft.

Beenden

Ggf. bestehende Verbindung zum Server trennen und Rocview beenden.


Menü Bearbeiten


Rückgängig machen

Der Rückgängig-Dialog ist nur verfügbar, wenn im Bearbeiten-Modus zuvor gelöschte Objekte vorhanden sind.

Suchen und ersetzen...

Öffnet den Dialog Suchen und ersetzen...


Menü Automatik


Automatikmodus

Wechselt den Status des Automatikmodus aus/ein.

Alle Loks/Züge starten

Startet alle verfügbaren Loks oder abhängig von Start mit allen Filtern. Nur im Automatik-Betrieb aktiv.

Heimat-Standort

Mit dieser Aktion erhalten alle passenden Loks (siehe Finder) einen Befehl, zum Heimat-Standort zu fahren.

Alle Loks virtuell starten

Alle Loks/Züge wieder starten

Startet alle Züge, die in der letzten Sitzung gestoppt wurden. Nur im Automatik-Betrieb aktiv.

Hinweis: Diese Option ist nur verfügbar, wenn alle Loks mit der Funktion Alle Loks stoppen angehalten wurden.

Rückmelder simulieren

Erlaubt, dass der Rückmelder-Status mit einem Maus-Klick geändert werden kann.
Ist standard-mäßig aktiv, kann aber deaktiviert werden, um im Auto-Modus Unfälle durch einen unbeabsichtigten Klick zu verhindern.

Aktionen aktivieren

Aktiviert oder deaktiviert die Verarbeitung von Aktionen und XmlScripts.

Alle Loks stoppen

Alle Züge erhalten den Befehl, im nächsten Block anzuhalten, bzw. aus dem aktuellen Block nicht los zu fahren. Nur im Automatik-Betrieb aktiv.
Siehe auch: Alle Züge wieder starten (von vorheriger Sitzung)
Dies hat keinen Einfluss auf die Automatik in Aufstellblöcken.

Zurücksetzen

:!: Bevor ein Zurücksetzten-Befehl verwendet wird, sollten alle Loks mit dem Befehl Alle Loks stoppen angehalten werden.

Zurücksetzen; außer Blockbelegung

Ein (Soft)-Reset für alle aktiven Objekte, wie Blockreservierungen und fahrende Loks. Die aktuellen Block-Reservierungen werden beibehalten!.
Nur im Automatik-Betrieb verfügbar.

Alles zurücksetzen

Ein (Hard)-Reset für alle aktiven Objekte. Die Block-Reservierungen werden ebenfalls zurückgesetzt!
Nur im Automatik-Betrieb verfügbar.


Menü Gleisplan


Bedienung

Der Standard-Modus, in dem die Objekte des Gleisplanes (Weichen, Signale, etc.) bedient werden können.
In diesem Modus ist der Gleisplan gegen versehentliche Änderungen gesperrt.

Plan bearbeiten

Der Bearbeitungs-Modus für den aktuellen Gleisplan wird aktiviert und der Dialog “Symbol hinzufügen” geöffnet.

Gleisplan löschen

Nur im Kontextmenü des Gleisplans
Diese Funktion ist nur im Modus “Plan bearbeiten” über das Kontextmenü möglich.
Nur die gerade angezeigte Gleisplan-Ebene wird nach einer Sicherheitsabfrage gelöscht.

Modulplan bearbeiten

Zum Bearbeiten eines Modulplanes.
Nur verfügbar, wenn der Gleisplan-Typ auf Modulplan eingestellt wurde.

Symbol hinzufügen...

Öffnet den Dialog “Symbol hinzufügen”, womit dem Gleisplan neue Symbole per Drag&Drop hinzugefügt werden können.

  • Mit der linken Spalte können Kategorien ausgewählt werden.
  • Die Symbole sind auf den Zoomwert des Gleisplans skaliert.
  • Aussehen und Eindruck der Symbole ist von den ausgewählten Themen abhängig.
  • Die Kategorie “Zubehör” enthält standardmäßig nur die Symbole für Ausgang, Text und Bahnübergang.
    Um auch Gebäude-Symbole zu erhalten, muss das Zubehör (Accessory)-Thema auf der Rocview-SVG-Registerkarte hinzugefügt sein.
  • Für die Symbole in der Kategorie “Straße” muss das Straßen (Roads)-Thema auf der Rocview-SVG-Registerkarte hinzugefügt sein.

Gleisplan hinzufügen...

Öffnet den Dialog Gleisplan-Eigenschaften (Name und Gleisplanebene) für den neuen Gleisplan.

Gleisplan Eigenschaften...

Öffnet den Dialog Gleisplan-Eigenschaften (Name und Gleisplanebene) des aktuellen Gleisplanes.

Plan-Baum

Öffnet den Dialog Plan-Baum.

Menü Tabellen


Alle Dialoge zur Einrichtung von Objekten sind von hier aus erreichbar.

Menü Steuerung


Gleisspannung ein

Ein- und Ausschalten der Gleisspannung.

Kommunikation aktivieren

Aktiviert/deaktiviert die Kommunikation mit der Zentrale. Unterstützt diese Biblotheken: (bisher)

  • cbus
  • ecos
  • p50x (tamsmc, opendcc)
  • virtual (Nur Info-Zeile; Keine Auswirkung auf die Funktionalität.)
  • xpressnet

Not-Halt

Im Automatik-Modus wird ein Nothalt-Befehl gesendet.
Wenn eine Zentrale keinen Nothalt unterstützt, wird es in einen “Gleisspannung AUS”-Befehl übersetzt.
:!: In Kombination mit der Server-Option Freigabe nach Nothalt erzwingen kann das zu Chaos führen.

Gleisspannungs-Steuerung...

Der Steuer-Dialog des Power-Manager wird geöffnet.

Betriebsbeginn

Es erscheint dieses Unter-Menü:

Anlage initialisieren

Um sicherzustellen, dass sich alle Weichen und Signale tatsächlich in der Position befinden, die auf dem Gleisplan angezeigt wird, werden sie mit diesem Befehl zweimal umgeschaltet.
Alle definierten Signale erhalten einen Befehl entsprechend des letzten bekannten Status oder 'ROT', wenn kein Status verfügbar ist.
Siehe auch: Kommandozeilenoptionen und Konsolen-Modus sowie die Rocrail-Einstellungen zur Initialisierung.

Folgende Zähler werden beim Intitialisieren zurückgestellt:

  • Achs-Zähler
  • Rückmelder-Zähler

Rückmelder abfragen

Alle Rückmelder-Adressen werden abgefragt und im Gleisbild aktualisiert.
Unterstützte Zentralen:

  • CBUS
  • LocoNet
  • Xpressnet
  • BiDiB

Betriebsende...

Für vollautomatisches Beenden und Ausschalten des gesamten Systems.
Nach Auswahl dieses Menüpunkts wird ein Passwort für das Ausschalten des Systems abgefragt, was nur Sudos und Administratoren erlaubt ist.

Wenn kein Passwort angegeben wurde, wird das Ausschalten (Schritt 5) übersprungen.
Nachdem der Rocrail-Server diesen Betriebsende-Befehl erhalten hat, werden folgende Schritte ausgeführt:

  1. Beenden des Automatik-Modus.
  2. Warten, bis alle Loks im Leerlauf-Status sind. Die voreingestellte Betriebsende-Auszeit beträgt 60 Sekunden.
  3. Die Clienten empfangen ein Herunterfahren-Ereignis und werden automatisch geschlossen.
  4. Alle angeschlossenen Zentralen erhalten einen Halt-Befehl mit einer optionalen Anforderung zum Herunterfahren.
  5. Wenn ein Passwort angegeben wurde, wird das Ausschalten des Systems gestartet. Wenn das erfolgreich ist, wird der PC heruntergefahren und ausgeschaltet.

Rückmelder-Monitor...

Öffnet den Dialog des Rückmelder-Monitors

Kurz-Kennungen senden

Einige Zentralen verwenden Kurz-Kennungen für die Benutzung mit externen Fahrreglern.

Gast-Lok...

Öffnet den Dialog zur Anmeldung einer Gast-Lok

Befehls-Recorder...

Modellzeituhr

Zeigt eine in der Größe änderbare Modellzeituhr.

Fahrdienstleiter

Der Fahrdienstleiter-Dialog wird geöffnet.

MIC...

Der Maussteuerungs-Dialog wird geöffnet.

Fahrregler...

Der Fahrregler-Dialog wird geöffnet.

Weichensteuerung...

Der Weichensteuerungs-Dialog wird geöffnet.

Fahrstraßensteuerung...

Der Fahrstraßensteuerungs-Dialog wird geöffnet.


Menü Programmieren


Spezielle Zubehör- und Mobil-Dekoder-Dialoge.


Menü Lesezeichen

Das Menü listet die letzten zehn Lesezeichen als Kennung und Registerkarten-Name.

Der erste Menü-Punkt öffnet den Dialog Lesezeichen bearbeiten.

Menü Ansicht


Meldungen löschen

Löscht alle Meldungen, die Rocview in den Bereichen Server und Zentrale anzeigt.

Sprache

Zur Auswahl der gewünschten Sprache der Benutzeroberfläche. Nach einer Neuauswahl fordert ein Dialog zum Neustart von Rocview auf.

Zoom

Hiermit kann die Darstellungsgröße der Gleisplanobjekte eingestellt werden. Mit dem Zoom-Dialog wirkt es direkt bei einer Schieber-Bewegung oder nach Auswahl im Kombinationsfeld:

Wenn der Schieber den Eingabefokus hat, können auch das Mausrad oder die Cursortasten verwendet werden. (Windows & Linux)

Lok-Bedienfeld

Für mehrere Instanzen von Rocview kann das Lok-Bedienfeld ausgeblendet werden, wenn der Gleisplan eingeblendet ist.

Lok-Steuerelemente

Gleisplan

Für mehrere Instanzen von Rocview kann der Gleisplan ausgeblendet werden, wenn das Lok-Bedienfeld eingeblendet ist.

Trace

Die Trace-Fenster von Server u. Zentrale ein-/ausblenden.
Diese Option abschalten, um Resourcen zu sparen.

Loks nach Adresse sortieren

Bei gesetzter Option erfolgt die Sortierung anstelle der Kennung nach der Dekoder-Adresse ”#__”

Lokanzeigefilter


Filtert die Lok-Steuerung auf die ausgewählte Antriebs- o. Zugart.

Lok-Spalten auswählen

(wxWidgets 3.02 oder höher.)
Dialog zur Auswahl der sichtbaren Spalten in der Tabelle der Loksteuerung.

Spalten der linken Liste sind in der Lok-Steuerung ausgeblendet.

Blockmenü

Dialog zur Auswahl der Menüpunkte im Block-Kontextmenü.

Kennungen anzeigen

Aktiviert werden die Kennungen bei Gleisplanobjekten wie z. B. Weichen, Signalen und Rückmeldern im Gleisplan angezeigt.

Zähler anzeigen

Die Zählerwerte von Rückmeldern werden formatiert als Zähler,Wagenzähler,Achszähler angezeigt.

Kennung Zähler

Zeige gesperrte Weichen

Die Verriegelung einer Weiche wird durch einen hellroten Hintergrund des Symbols angezeigt.

Zeige anstehende Weichen

Das Anstehen einer Weiche wird durch einen roten Hintergrund des Symbols angezeigt.

Raster einblenden

Zum Ein- / Ausblenden eines Rasters. Das Raster ist besonders bei der Bearbeitung eines Gleisplanes eine wertvolle Hilfe zum Ausrichten der Objekte.

Tooltip

Aktiviert / Deaktiviert die Anzeige von Tool-Tips zu Elementen unter dem Mauszeiger.

Vollbild

Aktiviert / Deaktiviert die Vollbilddarstellung von Rocview.

Hinweis: Unter Mac OSX ist das Menü nicht mehr erreichbar. CMD + U für die Rückkehr zum Normal-Bild verwenden.

Gleisplanfarbe

Zur vorübergehenden Einstellung der Hintergrundfarbe des Gleisplanes. Nach einem Neustart wird die ursprüngliche Farbe wiederhergestellt.

Tipp: Zur dauerhaften Änderung der Gleisplanfarbe kann das Gleisplan-Kontextmenü verwendet werden.


Menü Hilfe

Handbuch...

Link zum Online-Handbuch (Wiki) von Rocrail (Internetverbindung erforderlich).

Menü...

Link zur Rocview-Menü-Seite des Rocrail–Wiki (Internetverbindung erforderlich).

Forum...

Link zum Rocrail-Forum (Internetverbindung erforderlich).

Übersetzungen...

Link zu den Übersetzungen von Rocrail. Für angemeldete Benutzer ist es auf diesen Seiten möglich, Ergänzungen und Verbesserungen an den Übersetzungen vorzunehmen (Internetverbindung erforderlich).

Unterstützung...

Öffnet den Unterstützungs-Dialog, der auch die Gültigkeitsdauer des Unterstützungs-Schlüssels anzeigt.

Giling Computer Applications...

Link zur GCA-Seite des Rocrail-Wiki (Internetverbindung erforderlich).

RocNet...

Link zur RocNet-Seite des Rocrail-Wiki (Internetverbindung erforderlich).

Problemfall...

Der Dialog für das Dokumentieren eines Problemfalls wird geöffnet.

Trace...

Siehe: Trace-Filter

@Box...

Siehe: @Box

Info...

Öffnet das Rocview-Info-Fenster, in dem u.a. die verwendete Version von Rocrail und Lizenzinformationen angezeigt werden.

Ubuntu & Menü-Icons

Um Menü-Icons zu aktivieren dconf-tools installieren:

sudo apt-get install dconf-tools

dconf mit folgenden Parametern aufrufen:

dconf write /org/gnome/desktop/interface/menus-have-icons true
Mit Ubuntu 12.04 und 13.10 getestet.
1) Menü-Name = Link zur Beschreibung

Personal Tools