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Vorwort
Über unsere Firma

KeeYees Technology Inc. befinden uns in Shenzhen, das Silicon Valley

von China. Wir ist ein großer und professioneller Hersteller und

Verkäufer von elektronischen Produkten, der sich der Forschung und

Entwicklung von Open-Source Hardware, der Produktion und dem

Marketing widmet. Alle unsere Produkte entsprechen den internationalen

Qualitätsstandards und sind auf verschiedenen Märkten der Welt sehr

beliebt. KeeYees ist die beste Wahl in verschiedenen elektronischen

Modulen und Komponenten, die für Kunden aller Stufen geeignet sind,

um Arduino- und Raspberry Pi Kenntnisse zu erlernen. Darüber hinaus

verkaufen wir auch Produkte wie Zubehör für 3D-Drucker,

Steckverbinder und Terminalsätze, DIY-Teile und Werkzeuge, um Ihre

Arbeit oder Design-Herausforderungen von Zuhause, Schule bis hin zu

industriellen Anwendungen zu unterstützen!

USAmazon Geschäft Startseite:
https://www.amazon.com/shops/A2K4DGCC72N9AG
UKAmazon Geschäft Startseite:
https://www.amazon.co.uk/shops/A1F4U6XVWUBG1U
DEAmazon Geschäft Startseite:
https://www.amazon.de/shops/A1F4U6XVWUBG1U
FRAmazon Geschäft Startseite:
https://www.amazon.fr/shops/A1F4U6XVWUBG1U
ITAmazon Geschäft Startseite:
https://www.amazon.it/shops/A1F4U6XVWUBG1U
ESAmazon Geschäft Startseite:
https://www.amazon.es/shops/A1F4U6XVWUBG1U

https://www.amazon.com/shops/A2K4DGCC72N9AG
https://www.amazon.co.uk/shops/A1F4U6XVWUBG1U
https://www.amazon.de/shops/A1F4U6XVWUBG1U
https://www.amazon.fr/shops/A1F4U6XVWUBG1U
https://www.amazon.it/shops/A1F4U6XVWUBG1U
https://www.amazon.es/shops/A1F4U6XVWUBG1U
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JPAmazon Geschäft Startseite:
https://www.amazon.co.jp/shops/A7NY3JX21TGU2

KeeYees ESP32-CamWiFi und Bluetooth
Kamera Modul

https://www.amazon.es/shops/A1F4U6XVWUBG1U


www.KeeYees.com

3 / 23

Vorstellung der ESP32-CAM
Das ESP32-CAM ist ein kleines Kameramodul mit dem ESP32-S-Chip.

Neben der Kamera OV2640 und mehreren GPIOs zum Anschließen von

Peripheriegeräten verfügt sie über einen microSD-Kartensteckplatz, in

dem mit der Kamera aufgenommene Bilder oder Dateien gespeichert

werden

können.
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Eigenschaften
 Das kleinste 802.11b /g/ n-WLAN-BT-SoC-Modul.

 32-Bit CPU mit geringem Stromverbrauch kann auch den

Anwendungsprozessor bedienen.

 Bis zu 160 MHz Taktrate, Rechenleistung bis zu 600 DMIPS.

 Eingebauter 520 KB SRAM, externer 4MPSRAM.

 Unterstützt UART / SPI / I2C / PWM / ADC / DAC.

 Unterstützt die Kameras OV2640 und OV7670 mit integrierter

Blitzlampe.

 Bild-WiFI-Upload unterstützen.

 TF-Karte unterstützen.

 Unterstützt mehrere Schlafmodi.

 Eingebettetes Lwip und FreeRTOS.

 Unterstützt den Betriebsmodus STA / AP / STA+AP.

 Support Smart Config / AirKiss-Technologie.

 Unterstützung für lokale und Remote-Firmware-Upgrades der

seriellen Schnittstelle (FOTA).
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ESP32-CAM Videokommunikation und
Gesichtserkennung mit Arduino IDE

Die folgende Anleitung zeigt, wie Sie einen Video-Streaming-Webserver

mit Gesichtserkennung und -erkennung mit Arduino IDE einrichten.

Hinweis: In diesem Tutorial verwenden wir das Beispiel aus der arduino

esp32 Bibliothek. In diesem Tutorial wird nicht erläutert, wie Sie das

Beispiel ändern.

Erforderliche Teile
 ESP32-CAM mit OV2640

 FTDI Programmierer

 Female-Female Kabel Steckbrücken

Der ESP32-CAM wird ohne USB-Anschluss geliefert. Sie benötigen

daher einen FTDI-Programmierer, um Code über die U0R- und U0T-Pins

(serielle Pins) hochzuladen.

ESP32-CAM Pinbelegung
Die folgende Abbildung zeigt die ESP32-CAM Pinbelegung

(AI-Thinker-Modul).
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Es gibt drei GND-Pins und zwei Pins für die Stromversorgung: 3,3 V

oder 5 V.

GPIO 1 und GPIO 3 sind die seriellen Pins. Sie benötigen diese Pins, um

Code auf Ihr Board hochzuladen. Zusätzlich, GPIO 0 spielt auch eine

wichtige Rolle, da es bestimmt, ob sich der ESP32 im Blinkmodus

befindet oder nicht. Wenn GPIO 0 ist mit GND verbunden, der ESP32

befindet sich im Blinkmodus.

Die folgenden Pins sind intern mit dem microSD-Kartenleser verbunden:

GPIO 14: CLK

GPIO 15: CMD

GPIO 2: Data 0

GPIO 4: Data 1 (auch an die On-Board-LED angeschlossen)

GPIO 12: Data 2
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GPIO 13: Data 3

Installieren das Kameramodul

1. Schnallen Sie das Kameramodul in die Unterseite der Schnalle im

ESP32-Modul ein. Dies ist möglicherweise etwas mühsamer als Sie

denken.

2. Stellen Sie sicher, dass die weißen Linien auf der Unterseite des

Kameramoduls nach dem Anbringen der Schnalle nicht sichtbar sind. Der

Effekt ist der gleiche wie in Abbildung 2.

* Das Kameramodul fällt auch nicht herunter, wenn das ESP32-Modul

geschüttelt wird.

Videokommunikation Server
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Installieren Sie das ESP32-Add-On

In diesem Beispiel verwenden wir Arduino IDE, um die

ESP32-CAM-Karte zu programmieren. Daher müssen Sie Arduino IDE

sowie das ESP32-Add-On installiert haben.

Öffnen Sie Arduino IDE und klicken Sie auf File-> Preferences, wie

unten gezeigt.

Geben Sie dann https://dl.espressif.com/dl/package_esp32_index.json in

das Feld Additilnal Boards Manaper URLS ein und klicken Sie auf "OK"

(siehe unten).
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Klicken tools->board:->Blards Manager, geben Sie dann ESP32 in die

Popup-Oberfläche ein und klicken Sie auf Installieren. Wie nachfolgend

dargestellt:
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Nachdem Sie die obigen Schritte ausgeführt haben, können Sie das

Modul jetzt verwenden.

Schritte
1. Bereiten Sie eine Speicherkarte vor.

2. Setzen Sie die Speicherkarte und das Kameramodul OV2640 in den

Kartenhalter ein.

Schließen Sie die ESP32-CAM-Karte mit einem FTDI-Programmiergerät

an Ihren Computer an.

Folgen Sie dem nächsten Schaltplan:
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Wichtig: GPIO 0 muss mit GND verbunden sein, damit Sie Code

hochladen können.

2. Gehen Sie in Ihrer Arduino IDE zu File > Examples > ESP32 >

Camera und öffnen Sie das CameraWebServer Beispiel.

3. Der folgende Code sollte geladen werden.
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4. Stellen Sie sicher, dass Sie das richtige Kameramodul auswählen. In

diesem Fall verwenden wir das AI-THINKER Model. Kommentieren

Sie die 10. Codezeile #define CAMERA_MODEL_WROVER_KIT

und kommentieren Sie die 12. Codezeile #define

CAMERA_MODEL_AI_THINKER aus.

5. Sie müssen Ihre Netzwerkanmeldeinformationen in die folgenden

Variablen einfügen:
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const char* ssid = "REPLACE_WITH_YOUR_SSID";

const char* Passwort = "REPLACE_WITH_YOUR_PASSWORD";

Stellen Sie sicher, dass Sie die richtige SSID und das richtige Passwort

eingeben.

6. Jetzt kann der Code auf Ihren ESP32 hochgeladen werden.

Führen Sie die folgenden Schritte aus, um den Code hochzuladen:

Gehen Sie zu Tools > Board und wählen Sie ESP32 Wrover Module

Gehen Sie zu Tools > Port und wählen Sie den COM-Port aus, an den der

ESP32 angeschlossen ist.

Wählen Sie unter Tools > Partition Scheme die Option „Huge APP (3MB

No OTA)“.

Klicken Sie dann auf die Schaltfläche zum Hochladen, um den Code

hochzuladen.
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Wichtig: Wenn Sie den Code nicht hochladen können, überprüfen Sie,

ob GPIO 0 mit GNDs verbunden ist und ob Sie die richtigen

Einstellungen im Menü Extras ausgewählt haben. Sie sollten auch die

integrierte Reset-Taste drücken, um Ihren ESP32 im blinkenden

Modus neu zu starten.

8.Wenn das in der folgenden Abbildung gezeigte Problem während des

Herunterladens auftritt, klicken Sie auf der Entwicklungsplatine auf die

Schaltfläche zum Zurücksetzen.
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Wichtig: Wenn das Programm immer noch nicht auf die

Entwicklungsplatine heruntergeladen werden kann, müssen Sie die

Überbrückungskappe des FTDI232-Moduls auf 3,3 V stellen. Der

5-V-Pin auf der Entwicklungsplatine schaltet ebenfalls auf 3,3 V,

steckt die Stromversorgung ein und aus und lädt das Programm

herunter.

Nachdem der Download abgeschlossen ist, schalten Sie die

Überbrückungskappe am FIDI232-Modul auf 5 V und das Netzkabel

des ESP32-S-Moduls auf 5 V.

9.Trennen Sie nach dem Hochladen des Codes GPIO 0 von GND.

10. Abrufen der IP-Adresse

Öffnen Sie den seriellen Monitor mit einer Baudrate von 115200.

Drücken Sie die integrierte Reset-Taste von ESP32-CAM.

Die ESP32-IPAdresse sollte im seriellen Monitor ausgedruckt werden.
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11. Zugriff auf den Videokommunikation Server

Jetzt können Sie auf Ihren Kamera-Streaming-Server in Ihrem lokalen

Netzwerk zugreifen. Öffnen Sie einen Browser und geben Sie die

IP-Adresse des ESP32-CAM ein. Klicken Sie auf die Start Streaming, um

das Videokommunikation zu starten.
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Sie können auch Fotos aufnehmen, indem Sie auf die Get Still klicken. Es

gibt auch verschiedene Kameraeinstellungen, mit denen Sie die

Bildeinstellungen anpassen können.

Schließlich können Sie die Gesichtserkennung und -erkennung

durchführen.

Klicken Sie auf die Face Detection und Face Recognition Tasten (wenn

die Auflösung größer ist, müssen Sie sie verkleinern).
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Sie müssen ein neues Gesicht registrieren. Es werden mehrere Versuche

unternommen, das Gesicht zu retten. Nach der Registrierung eines neuen

Benutzers sollte er das Gesicht später erkennen (Betreff 0).

Und das ist es. Jetzt können Sie Ihren Videokommunikation Webserver

mit Gesichtserkennung und -erkennung verwenden.

Probleme, die Sie möglicherweise haben
Problem 1

camera_probe(): Detected camera not supported

SCCB_Write(): SCCB_Write Failed addr:0x30, reg:0xff, data:0x01, ret:-1

SCCB_Write(): SCCB_Write Failed addr:0x30, reg:0xff, data:0x01, ret:-1

SCCB_Write(): SCCB_Write Failed addr:0x30, reg:0x12 data:0x01,

ret:-1

esp_camera_init(): Camera probe failed with error 0x20004

Grund: OV2640 Kameramodul ist nicht richtig gesteckt!
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Problem 2

brownout detector was triggered

Grund: Dieses Problem kann auftreten, wenn Sie eine Verbindung zu

WiFi herstellen! Das FT232RL FTDI Mini-USB-TTL-Konvertermodul

verfügt über eine Triggerfunktion. Wenn die Spannung zu niedrig ist,

wird die Karte automatisch neu gestartet, um die Karte zu schützen.

Wie man es löst?

1. Stellen Sie den USB-TTL auf 3,3 V ein.

2. Schließen Sie es wie in allen Diagrammen gezeigt an die ESP32-CAM

an.

3. Verbinden Sie Io0 und gnd. （Stellen Sie sicher, dass die Pins korrekt
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sind. Es ist sehr wichtig.)

4. Schalten Sie den Code ein und laden Sie ihn hoch.

Testen Sie nun die ESP32-CAM

1. Entfernen Sie den IO0 und den GND-Jumper.

2. Ändern Sie den USB-TTL auf 5V (Ändern des Pins).

3. Ändern Sie die Spannung am ESP32-CAM auf 5V Pin.

4. Einschalten.

5. Öffnen Sie den seriellen Monitor.

6. Drücken Sie die Reset-Taste am ESP32-CAM.

7. Rufen Sie die IP-Adresse ab.

Problem 3

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

configsip: 0, SPIWP:0xee

clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:

0x00

mode:DIO, clock div:1

load:0x3fff0018,len:4

load:0x3fff001c,len:1100

load:0x40078000,len:10088
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load:0x40080400,len:6380

entry 0x400806a4

Gund: Keine IP-Adresse Wifi ist nicht erfolgreich verbunden.

Serial.println("checking wifi connecting");

Serial.print("connect fail,retry");

Stellen Sie sicher, dass die WLAN-SSID und das Passwort zu 100%

korrekt sind.

Problem 4

Upload fehlgeschlagen
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Stellen Sie sicher, dass die RXD- und TXD-Pins des ESP32-S-Moduls

korrekt mit den FTDI232-Modulpins verbunden sind.

Drücken Sie die Reset-Taste, um zu bestätigen, dass das Licht an ist.

Nachdem der Upload erfolgreich war, trennen Sie GND und GPIO0.

Zurück zum CameraWebServer, um neu zu starten.
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Wenn dies immer noch fehlschlägt, ändern Sie den USB-TTl auf 5 V und

die Spannung am ESP32-CAM auf 5 V. Dann zurücksetzen.


