User Tools

Site Tools


develop-corner-en

Developer corner


General information

Prerequisites

Linux

  • libusb-1.0-0-dev
    Debian: sudo apt-get install libusb-1.0-0-dev
    Debian9 (stretch): apt-get install libusb-dev libgusb-dev
    OpenSuSE: libusb-1_0-devel
    Fedora/RedHat/CentOS: yum install libusb–devel

Compile Rocrail

Linux

Windows

Apple macOS

Debug the Rocrail Server

Arduino Projects

Building packages

API Error Codes

Dump Pre Processor Defines

gcc -dM -E - < /dev/null


VirtualBox

Some distribution do not have VB support installed by default.

Debian

develop-corner-en.txt · Last modified: 2019/04/20 16:27 by rjversluis