User Tools

Site Tools


track-diagram-de

Erstellen/Bearbeiten eines Gleisplans

Erstellen eines Gleisplans

Das Erstellen eines Gleisplans kann entweder in Offline oder in Online Modus erfolgen.

Rocview im offline-Modus

Gleisplan hinzufügen...

Menü → Gleisplan → Gleisplan hinzufügen… öffnet den Dialog "Gleisplan-Eigenschaften":


Überschrift

Als Überschrift ist der Name des Gleisplans einzugeben. Dieser erscheint hinterher als Beschriftung der Register-Karte.

Ebene

Die Ebene ist die Etage im vertikalen Aufbau der Anlage, in der die Objekte des Gleisplans positioniert sind. Der Schattenbahnhof käme also auf Ebene 0, die Bergbahn auf die höchste Ebene.

:!: Achtung: Die Ebenen-Nummer. darf nicht auf dieselbe Nummer einer bereits bestehenden Ebene eingestellt bzw. geändert werden.
Die andere Ebene geht damit verloren und ist normal nicht wieder herzustellen.

Registerkarten-Index

Nur Anzeige der mit "Kontext-Menü → Links/Rechts" eingestellten Registerkarten-Position. Wenn die Position unverändert ist, wird -1 angezeigt.

Symbol Präfix

Wenn ein Symbol-Präfix definiert ist, wird dieser dem Vorschlag im Kennungs-Dialog vorangestellt bzw. der Vorschlag wird dem Objekt direkt als Kennung zugewiesen.

Der Dialog kann auch zur Bearbeitung eines geöffneten Gleisplans aufgerufen werden:

  • Menü → Gleisplan → Gleisplan Eigenschaften
  • freier Raster in der Gleisplangrafik Kontext-Menü → Eigenschaften


Nach Klick auf OK werden die Register-Karten aktualisiert. Das Ergebnis sieht dann so aus:

tab_gleisbild.jpg

Im Kontext-Menü des Gleisplans kann mit Links/Rechts die Position der dargestellten Ebene in der Reihenfolge der Registerkarten geändert werden. Der Registerkarten-Index zeigt die eingestellte Position.

Nun kann der Gleisplan über "Datei / Speichern unter" im Dateisystem des Clients als .xml-Datei abgespeichert werden. Wenn der Rocrail-Client auf dem selben Rechner läuft wie der Rocrail-Server, ist es angebracht die Gleisplan-Datei im Arbeitsverzeichnis des Rocrail-Servers abzuspeichern.

Einen Gleisplan auf den Server laden

Diese Funktion wird benötigt, wenn der Rocrail-Server und Rocview auf verschiedenen Rechnern laufen. Alternativ kann der Gleisplan natürlich auch mit den Bordmitteln des Betriebssystems in das Arbeitsverzeichnis des Rocrail-Servers kopiert werden. Um einen Gleisplan auf den Server zu laden muss der Rocrail-Server gestartet sein. In Rocview wird nun über Menü "Datei → Hochladen" das Dialogfenster "Gleisplandatei öffnen" aufgerufen.

Hier wird die hochzuladende Gleisplan-Datei ausgewählt. Nach Klick auf öffnen wird die Datei unter dem gleichen Namen im Arbeitsverzeichnis des Rocrail-Servers gespeichert. Ein Info-Fenster bestätigt den Vorgang.

Nach Klick auf den OK Button ist der Vorgang abgeschlossen.

Nun muss dem Server mitgeteilt werden, dass er beim nächsten Start die neue Gleisplan-Datei verwenden soll. Dazu Rocview beenden, Rocrail und anschließend Rocview starten. Dadurch verbindet sich Rocview mit Rocrail. Unter "Datei → Rocrail Eigenschaften …" wird in der Register-Karte "Allgemein" der Name der neuen Gleisplandatei eingetragen.

Um den neuen Gleisplan zu aktivieren, ist es nötig, den Rocrail-Server neu zu starten.


Bearbeiten eines Gleisplans

Ein Gleisplan kann im Online- als auch im Offline-Modus, also ohne Verbindung zum Rocrail-Server bearbeitet werden.
Im Online-Modus kann der gerade verwendete Gleisplan bearbeitet werden, im Offline-Modus ein beliebiger im Dateisystem gespeicherter Gleisplan.

Im Offline-Modus muss über "Datei → Öffnen…" ein vorhandener Gleisplan geladen oder über "Datei → Neu" ein neuer Gleisplan erstellt werden.
Im Online-Modus genügt ein Klick auf "Gleisplan → Plan bearbeiten", um in den Bearbeitungs-Modus zu gelangen.

Die Option Kennungs-Dialog öffnen in "Datei → Rocview-Eigenschaften…" bestimmt die zwei Arten, Objekt-Kennungen zu definieren:

  1. Es erfolgt eine automatische Vergabe der Kennung für ein neues Objekt
  2. Ein Dialog wird geöffnet, der die automatische Kennung als Vorschlag anbietet, der übernommen oder geändert werden kann.

Einzelheiten in der Options-Beschreibung.



Im Bearbeitungs-Modus können Symbole des Gleisplans hinzugefügt oder geändert werden.
Mit dem Dialog Symbol hinzufügen ist das auch per Drag&Drop möglich.

gleisplan_bearbeiten2_de.jpg gleisplan_bearbeiten1_de.jpg

Eine Erläuterung der verschiedenen Objekte eines Gleisplans ist im Kapitel Objekte eines Gleisplans zu finden.

Drehen

Dreht die komplette Ebene um 90°, 180° oder 270°.
Diese Option ist nur verfügbar, wenn Rocview mit dem Rocrail-Server verbunden ist.
Für diesen Vorgang gibt es keine "Rückgängig"-Funktion. Es wird empfohlen, vorher ein Backup des Gleisplans vorzunehmen.

Auswählen

Der Auswahl-Dialog wird geöffnet.

Gleisplan löschen

Dieser Menü-Punkt wird nur im Modus "Gleisplan bearbeiten" angeboten.
Nur die gerade angezeigte Gleisplan-Ebene wird nach einer Sicherheitsabfrage gelöscht.

Überlappende Objekte - "Gesundheits-Check"

Befinden sich mehrere Objekte fehlerhaft an gleicher Position im Gleisplan, kann das in der Regel nicht über die grafische Oberfläche ermittelt und bearbeitet werden.
Durch erneutes Plankonsistenz prüfen lassen sich ggf. einige Hinweise zu problematischen Objekten auflisten.


Individuelle Hintergrund-Farbe

Mit dem Gleisplan-Kontext-Menü (Rechtsklick auf eine freie Stelle des Gleisplans) kann eine individuelle Hintergrund-Farbe ausgewählt werden. :

Im Gegensatz zum Menü Ansicht wird diese Einstellung gespeichert und ist auch nach einem Neustart wirksam.


Ebene verschieben

Um eine Ebene auf eine andere Registerkarte zu verschieben, können die Links/Rechts-Befehle des Kontext-Menüs verwendet werden:

Der Index der Registerkarte wird in der plan.xml-Datei gespeichert.

track-diagram-de.txt · Last modified: 2018/11/12 08:56 (external edit)